关于FastReport.Net升级版本编译失败解决方案
作者:C/S框架网  发布日期:2013-04-24 22:31:59
  关于FastReport.Net升级版本编译失败解决方案


框架从V1.0到V3.0共使用了3个版本:

FastReport .Net 1.0.203 ,要求.NET Framework 3.5以下
FastReport .Net 1.2.47 ,要求.NET Framework 3.5以下
FastReport .Net 1.6.18 ,要求.NET Framework 4.0或以上

另外有其它更高的版本,要求程序集NET Framework 4.0或以上。


开发环境配置及报表组件安装:

1. FastReport .Net 1.0.203,直接复制FastReport*.dll到debug目录下,然后在VS工具栏手工加进来,
参考:http://www.csframework.com/archive/1/arc-1-20110609-1526.htm

2. FastReport .Net 1.2.47 ,需要安装,点FRNet_2_47_Pro.exe安装,然后在Program Files\FastReport目录下复制FastReport*.dll到debug目录下,然后在VS工具栏手工加进来,
参考:http://www.csframework.com/archive/1/arc-1-20110609-1526.htm

3.FastReport .Net 1.6.18 ,直接复制FastReport*.dll到debug目录下,然后在VS工具栏手工加进来,
参考:http://www.csframework.com/archive/1/arc-1-20110609-1526.htm

注意:安装此版本必须将所有工程的.NET程序集版本改为4.0,否则无法编译。
如有疑问,请QQ联系我,谢谢您们的支持!
上一篇 下一篇